Jump to content
Sign in to follow this  
Guest pierre27

Mastera Programmer

Recommended Posts

Guest pierre27

Hallo,

zit al dagen te proberen een goldcard met de Mastera te proggen, maar krijg steeds, wat/hoe ik het ook probeer, de volgende fout:'"Error writing EEPROM"'

Ik laad in 1 een hex-file en in 2 een bin-file, de loader gaat goed, maar dan krijg ik die error.

Als ik in 1 en 2 geen file laat laden, dan doet hij alles normaal, loader-eeprom-verifying-enz., echter zodra er een file wordt geladen gaat het fout.

Hoe kan ik controleren of mijn card nog goed is???

Ik heb ook de pic al erased, niets helpt.

groetjes

Pierre

Share this post


Link to post
Black Tiger

Het schijnt dat nieuwere GW's nogal eens wat meer spanning nodig hebben.

Probeer de spanning eens wat hoger te zetten, de Ghostwriter heeft dit probleem ook.

Volgens mij staat hier ergens zelfs nog een topic over de Mastera met dit probleem, dat zou je ook nog eens door kunnen lezen.


Greetings, Black Tiger

Share this post


Link to post
satjan

sorry Blacktiger het zal niet meer gebeuren he was een foutje

Share this post


Link to post
Black Tiger

Thanks Satjan.


Greetings, Black Tiger

Share this post


Link to post
Guest pierre27

Black Tiger,

bedankt voor je reaktie!!

Heb je raad opgevolgd, omdat ik de Topic niet kon vinden, en mijn 9 volt verhoogd naar 12 volt.

Het resultaat bleef hetzelfde, zoals boven omschreven, weer.....error writing eeprom..........!

Hoe kan ik controleren of mijn kaart nog goed is en niet stuk.

Is daar een testprogramma voor???

groetjes

Pierre

Share this post


Link to post
Guest satdigital

Met welk programma probeer jij die GW te proggen ?

Share this post


Link to post
Dr.Z

Gw'tje stuk misschien??? ik heb er ook al een stapeltje van liggen die deze meldingen geven.

Verse GW proberen is misschien een oplossing.


"Al het goede in het leven is illegaal,immoreel of dikmakend"

Share this post


Link to post
Guest pierre27

Satdigital,

ik gebruik de

picv35.hex

en de

v35afile0706.bin.

x

x

Drz,

jij hebt er een stapeltje liggen,

echter ik heb er maar eentje!!!!

Gelijk gekocht met mijn Mastera.!

gr.

Pierre

Share this post


Link to post
Guest theGIZMO

@pierre27,

 

Nee, satdigital bedoelt met welke programma (dus niet type files) probeert te proggen...IC-Prog, Chip-Cat etc. ?

Share this post


Link to post
Guest pierre27

Gizmo,

sorry..............

ik gebruik CHIPCAT 2.3

de allernieuwste.

Pierre

Share this post


Link to post
Guest theGIZMO

Hmmm, dat zou toch zonder problemen moeten kunnen...echt een gerichte oplossing heb ik niet voor je want ik heb deze melding niet eerder gezien. Ervan uitgaande dat de files en GW (helaas dat je deze niet kunt swappen) OK zijn:

 

- varieer de delay van het proggen,

- lukt een erase en blank check wel ?

- wat gebeurd er bij een verify ?

- probeer eens andere files,

- IC-Prog al geprobeerd ?

Share this post


Link to post
Guest pierre27

Gizmo,

Wat bedoel je met " Varieer de Delay van het proggen" ????

En met IC-Prog al geprobeerd????

Andere files proberen, ....heb ik niet!!!!

De rest heb ik uitgevoerd!!!!

 

Een Erase en een Blanc check gaat wel, zie hieronder.

Laat ik een Blanc check Pic uitvoeren met geladen files, dan krijg ik terecht de error: Device not blank at adress $0000.

Als ik daarna de Pic "erased" en dan een blanc check uitvoer dan gaat alles normaal.(Program memory)

 

Het verifieren gaat als volgt:

Als ik de pic laat verifieren zonder geladen files, krijg ik Program en Data Memory, doet hij normaal.

Laat ik dit doen met geladen files, dan krijg ik een error bij Program Memory:

Verify error at adress $0000. (is dit normaal???)

 

als ik (READ) de Pic c/q 24c16 laat lezen, verloopt alles normaal en ben ik de files, welke ik geladen heb kwijt.

Als ik dan laat schrijven F3 (Write pic & 24c16) zonder geladen

files, dan gaat alles normaal: Loader-Eeprom -Erasing-Program memory (2X)-Data memory (2x).

 

Als ik met geladen files laat schrijven, krijg ik weer :

"Error writing Eeprom"

Ik hoop dat je er wat aan hebt voor een oplossing.

gr.

Pierre

Share this post


Link to post
Guest theGIZMO

@pierre27,

 

Ik heb eindelijk bij mij dezelfde fout kunnen reproduceren, het zat hem inderdaad in de delay instelling. Default staat deze (onder configuration --> 2de icon bovenaan) in het midden, dit is waarschijnlijk bij jou nog aan een te snelle kant. Daarom verplaatst deze helemaal naar rechts...het proggen duurt dan wel iets langer wel maar gaat uiteindelijk wel goed.

Share this post


Link to post
Guest pierre27

Gizmo,

hardstikke bedankt dat je zoveel moeite voor mij doet, echter...................allemaal voor niks!!!

Ik heb hem op alle standen uitgeprobeerd, te beginnen bij uiterst

rechts, zoals je voorstelde...........steeds dezelfde error, behalve toen hij helemaal links stond, toen kreeg ik het bericht dat de loader does not work!!!!

Ik heb zelfs 6 Mhz veranderd in 3.5 Mhz, ook zonder resultaat.

Zijn wij nu aan het einde van ons latijn?????

gr

Pierre

Share this post


Link to post
Guest theGIZMO

@pierre27,

 

Nee, zo snel geven we niet op...check even of je de volgende instellingen hebt

 

Chip-Cat:

-Clock 6,0 MHz,

-Speed rechts,

-Clear all memory before loading enabled,

-OSC Off,

-WDT Off,

-PWRT Off,

-CP Off.

 

OS:

-Communications Port 115200,

-Data bits 8,

-Parity None,

-Bits 1,

-Flow Control None.

 

Dit zijn de instellingen waarbij het bij mij werkt (W2K), 'loader does not work' verschijnt namelijk wanneer ik Flow Control enable.

De aanhouder overwint !

Share this post


Link to post
Guest pierre27

Gizmo,

gecontroleerd en de antwoorden staan er achter.

 

Chip-Cat 2.3:

-Clock 6,0 MHz, (acc)

-Speed rechts, (acc)

-Clear all memory before loading enabled, (was al aangevinkt)

-OSC Off, (staat er niet bij, ik kan kiezen uit: RC-LP-XT en HS)

-WDT Off, (acc)

-PWRT Off, (acc)

-CP Off. (acc)

 

OS:

-Communications Port 115200, (acc)

-Data bits 8, (acc)

-Parity None, (acc)

-Bits 1, (acc)

-Flow Control None. (ik heb ISDN met een smartvox v.120 modem

flowcontrol is niet aanwezig, tenminste ik kan het niet vinden)

 

Ik heb weer proberen te schrijven en kreeg weer die ERROR!!!!!

gr.

Pierre

Share this post


Link to post
Guest theGIZMO

@pierre27,

 

Denk je niet dat die Smartvox de boel verziekt ? Is dat een extern type die op dezelfde COM-poort aangesloten zit ? Ik ben namelijk ISDN-adapters in de praktijk tegengekomen (Dynalink bijvoorbeeld) die de ser*.sys driver van Windows aanpassen. De Flow-Control optie is standaard binnen Windows te definieren (Hardware, Xon/Xoff, None).

 

Heb je misschien ergens een PC tot je beschikking waar geen exotische randapparatuur op de COM-poorten zit ?

Share this post


Link to post
Guest pierre27

Gizmo,

de flow-control heb ik gevonden, stond op xon/xoff, heb hem op GEEN gezet.(writing weer met error!!!)

Ik heb card/programmer al op een andere computer uitgeprobeerd die hier naast mij staat, voordat ik dit probleem op het board heb gezet, (vandaag nog een keer gedaan) met precies hetzelfde resultaat.

Ik stel mij wel in verbinding met de satwinkel, waar ik beide artikelen heb aangeschaft op 9 juni jl., misschien kapotte Programmer en/of Goldcard!

Hardstikke bedankt voor de hulp, jammer dat wij er niet uikwamen!!!

Ik houd je op de hoogte!!!

gr.

Pierre

Share this post


Link to post
Guest satdigital

Pierre27,

we gaan de oplossing snel nemen.

stuur mij een mailtje.

 

ik hoor je wel.

Share this post


Link to post
Guest pierre27

Hallo allemaal,

deze posting kan gesloten worden, daarom wil ik nogmaals iedereen danken voor hun reaktie(s) en suggestie(s), het is leuk en leerzaam en schept een band, indien samen naar oplossingen worden gezocht !

Mede daardoor ben ik weer wat wijzer geworden en het resultaat was, dat ik de fout "error writing Eeprom" niet meer te zien kreeg, waarschijnlijk een te grote laadfile.

Nogmaals mijn dank

groetjes

Pierre

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  




  • Hosting Fun

×
×
  • Create New...

Important Information

By clicking the accept button you specifically agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. If you don't agree, please leave this site.