Jump to content
Sign in to follow this  
Guest Stingertje

Kan niet meer de bootloader beschrijven

Recommended Posts

Guest Stingertje

IK heb een MM9500 gekregen van mijn vriend die rare kuren heeft. Het laatste wat hij gedaan heeft is een nieuwe bootloarder erin gestopt (B2.010UNs of zoiets) en nu knippert de bootloader afwisselend met init x2 en kan de MM dus niet meer opstarten. Wanneer ik transbdm gebruik zegt hij dat ik de bootloader niet kan beschrijven, nochtans de jumper zit op zijn plaats. Weet iemand wat hier gebeurt is en heeft iemand daar een oplossing voor.

 

Thanks

Share this post


Link to post
Guest petertje

probeer het hele zaakje eens te wissen. dwz. de gebruikte software (DVB/FTA), en hierna de bootloader. hierna het gebied selecteren waar de bootloader komen moet, bootloader flashen, etc etc. heb dit ook eens gehad toen ik de fout had gemaakt de bootloader per ongeluk in het gedeelte te flashen waar normaal het programma staat. dit zou moeten werken, alleen je bent al je settings kwijt die je ooit in DVB2000 hebt gedaan. het kan ook zijn dat je een flash eeprom hebt opgeblazen, hoe je dit kan zien weet ik niet, dat zal je op een board moeten bekijken waar de nokia specialisten zitten.

succes.

peter.

Share this post


Link to post
Guest Black Tiger

Zorg ook dat je in elk geval een bootloader 2.10uns bij de hand hebt.

 

Het kan namelijk zijn dat als er ooit een 2.10 in gezeten heeft dat ie geen 2.00 meer accepteert.

 

Share this post


Link to post
Guest FranX

Volgens mij werkt een 9500 alleen goed met de oude vertrouwde b2.00uns

 

Het beste kan je met de BDM eerst de HELE! flash leeg gooien (Erase in Transbox)

Daarna bootloader erin, en dan gewoon via serieel de software erin spelen.

 

Bij menig ontvanger die 'vreemd' deed was dit een prima oplossing...

 

Gr FranX

 

Share this post


Link to post
Guest Stingertje

Thanks,

 

Maar het probleem is dat ondanks de jumper erop zit ik geen toegang krijg tot de bootloader via het programma transbdm. De software kan wel nog ingeladen worden, ik kan dit checken omdat bij DVB2000 er init x2 opkomt en bij DVB98 CL init. Ligt dit nu aan het programma of aan de hardware van de MM. Kent er iemand een ander programma om te programmeren via de bdm die share/freeware is.

 

Thanks

Share this post


Link to post
Guest MAS3

Ik meen mij te herinneren dit al eens eerder gezien te hebben in een posting ergens.

Toen bleek dat er kortsluiting gemaakt was tussen eenvan de pinnetjes van XP06 en het blik dat ernaast zit.

In dat geval is er een transistor kapot gegaan.

Ik zal je even het programma dat ik gebruik mailen, dat is bd32win en daar werk ik al heel lang met veel plezier mee.

Het komt wel eens voor dat het niet in een keer wil lukken, maar dan moet je het gewoon nog een keer proberen.

De werking van het proggie wijst zichzelf.

 

Share this post


Link to post
Guest Black Tiger

Dat klopt mas3.

Dat proggie is niet zo mooi als tranxbdm, echt een heel simpel ding, maar werkt vrijwel altijd en meestal ook als tranxbdm geen zin meer heeft. smile.gif

 

Share this post


Link to post
Guest MAS3

Voor diegene die hier meeleest en er wat aan kan doen:

De link onder de reply knop is gecorrumpteerd!

Ik heb hem door plakken van het topic nummer over het vorige topicnummer achterhaald.

 

 

@Stingertje: hier komt het technische verhaal:

 

Voordat ik begin: PAS OP; ER STAAT 220 VOLT OP DE BOX ALS DE STEKKER ERIN ZIT !!

 

De transistor die defect kan zijn, is TS 03; een 2SD1858.

Hij zorgt ervoor dat er 12 volt in de diverse delen van de ontvanger terecht komt.

Deze 12 volt moet dus op een van de pinnetjes van de jumper staan.

Ik kan je niet vertellen welk pinnetje dat is, omdat er verschillende versies van jouw box in omloop zijn met de jumpers anders geplaatst.

 

De transistor bevindt zich op de volgende plaats:

Als je de box open maakt en het front verwijdert, en dan met de voorkant naar je toe zet, dan zitten er rechts 3 koperen koellichamen achter elkaar.

Wees zeer voorzichtig met deze koellichamen, want daar kan de voedingsspanning van 220 volt opstaan!!

Achter het voorste koellichaam zit een elco(condensator), CS 34.

Achter die condensator zit transistor TS 03, met links daarvan een weerstand van 0 Ohm.

Weer links van die weerstand zitten elco CS 41 en condensator CS 42.

Over condensator CS 42 (is het gemakkelijkst te meten) moet 12 volt staan als de box aanstaat en de transistor goed is.

Als de box standby staat, is deze 12 volt niet aanwezig.

( daarom heet deze spanning 12V_OP(erate))

Het zou nog kunnen zijn dat de transistor het wel doet, en de weerstand van 0 Ohm defect is.

Dat kun je zien door over de weerstand te meten als er 12V over staat, is ie kapot.

De weerstand kan door een stukje draad vervangen worden.

Toch is de kans dat de transistor defect is het grootst.

Als je zeker wil weten of de transistor zelf wel defect is en niet iets ervoor:

Meet aan de bereikbare kant van spoel LS 08 of je die 12 volt weer hebt, ook als de box op standby staat.

Dit meet je ten opzichte van het blik aan de achterkant van de box.

Deze LS 08 ziet eruit als een blauwe druppel en zit helemaal rechts op de print zoals zojuist beschreven, daar zitten nog twee identieke delen vlak bij.

De box kan niet ingeschakeld worden als TS 03 defect is, want dat is ook een deel van de functie van deze transistor.

 

Zo, dat is een heel verhaal dus doe er je voordeel mee.

Als er nog vragen/opmerkingen zijn dan hoor ik het wel.

 

Suc7.

 

Share this post


Link to post
Guest Stingertje

THanks, ik ga dat morgens eens goed bekijken.

 

Intussen heb ik al wat vorderingen gemaakt :

 

Wanneer ik de jumper verwijder en terug plaats tijdens dat hij geconnecteerd is met een programma, kan ik zogezegd wel aan het bootblock, maar wissen of schrijven schijnt niet te lukken ook bij het lezen dan heeft hij iets wat er niet moet zijn. Is er iemand die eventueel de spanning ken die over die jumper staat t.o.v. de massa, nu staat er rond de 3 V op , als dit een andere waarde zou moeten zijn kan ik dit misschien met een externe voedingsbron aansturen.

 

Nogmaals bedankt

Share this post


Link to post
Guest kollenburg

Hoi,

 

Ik zou oppassen met het exstern aanbrengen van spanning!

 

De Jumper zit, volgens het schema, in iedergeval aan een kant aan de processor.

Dit zal dus altijd een standaard logica signaal van max 5v zijn.

Als de spanning die je meet via een pull-up weerstand loopt, kan de 3 volt die je meet best wel eens kloppen..

 

Of het zou zo zijn kunnen zijn, dat de komplete 5v spanning nog maar 3v is, dan krijg je ook rare dingen...

 

Het makkelijkste kun je die spanning meten bij een van de 74HC.. IC`s

Tussen pootje 7 en 14 (met de inkeping links is pootje 7 rechtsonder, en pootje 14 linksboven)

 

Sucsess met de reparatie.....

 

Groeten,

Erik.

 

Share this post


Link to post
Guest MAS3

Bedankt voor je bijdrage, Erik, maar doordat het board door de engel des wrakes werd bestookt en een actuele backup houden van een drukbezocht board met makken geen kattepies is, is wat je zag niet de hele thread.

Stingertje kon niet langer wachten, heeft de stoute schoenen aangetrokken en er een externe 12 volt op gezet.

Resultaat: werken!.

Overigens moet je nog maar eens kijken in het schema: daar zie je dat de 12 volt niet naar de processor gaat, maar naar de EEPROM.

Een EEPROM kan (niet in alle gevallen, is type afhankelijk) alleen geprogrammeerd worden als de programmeer spanning anwezig is.

Dat is meestal een spanning die hoger is dan de voeding van het ic.

Kijk maar eens hoe dat in je JDM progger werkt, dat berust op hetzelfde principe: de PIC kan alleen geprogd worden als de reset-aansluiting geen GND, geen 5V, maar hoger is.

De bootloader zit dus in EEPROM IP02.

Hetzelfde draadje van de EEPROM kan ook door de processor aangesproken worden (met 5 volt), maar dan wel via een diode.

De 12 volt komt dus alleen op de processor in het onwaarschijlijke geval dat die diode sluiting zou gaan maken.

 

Stingetje en ik waren er inmiddels al uit.

Hij heeft de transistor bij de lokale transistor boer besteld en erin gezet, en klaar was kees.

Ik had hem aangeraden er een BD 139 in te zetten als de transistor niet te krijgen was, want die is pin-compatible, en kan veel meer stroom schakelen.

Het ding wordt hier alleen als schakelaar gebruikt zoals je in het schema kan zien, dus dat mag geen probleem zijn.

 

Share this post


Link to post
Guest kollenburg

Hoi,

 

Tja...je hebt gelijk, een beetje te snel gekeken, denk ik.

 

In iedergeval een mooi voorbeeld, dat als je een een gokje waagt, en gewoon doet wat je denkt, het ook goed kan gaan :-))

 

Groeten,

Erik.

 

Case closed....

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  




  • Hosting Fun

×
×
  • Create New...

Important Information

By clicking the accept button you specifically agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. If you don't agree, please leave this site.