Jump to content
Sign in to follow this  
Guest hagar

flashen

Recommended Posts

Guest hagar

Als ik in expert mode probeer een nwe image te laden krijg ik 2 fouten.

Ofwel zegt ie Kann datei nicht offnen als ik een nwe img erin wil plaatsen.

Ofwel zegt ie kan kann das mtd device nicht offnen.

 

Probeer ik via boot manager dan krijg ik het volgende

 

debug: DDF: Calibrating delay loop... debug: DDF: 66.76 BogoMIPS

debug: BMon V1.0 mID 02

debug: feID 00 enxID 03

debug: fpID 52 dsID 01-fa.a0.c4.07.00.00-fe

debug: HWrev 01 FPrev 0.30

debug: B/Ex/Fl(MB) 32/00/08

dbox2:root> debug:

BOOTP/TFTP bootstrap loader (v0.3)

debug:

debug: Transmitting BOOTP request via broadcast

debug: Given up BOOTP/TFTP boot

boot net failed

 

Flash-FS bootstrap loader (v1.5)

 

Found Flash-FS superblock version 3.1

Found file /root/platform/philips-dbox2/kernel/os in Flash-FS

debug: Got Block #0052

 

will verify ELF image, start= 0x800000, size= 203252

verify sig: 262

Branching to 0x40000

 

 

PPCBoot 1.1.6 (TuxBox) (Jul 12 2002 - 20:57:43)

 

CPU: PPC823ZTnnB2 at 65.900 MHz: 2 kB I-Cache 1 kB D-Cache

Watchdog enabled

Board: DBOX2, Phillips

I2C: ready

DRAM: 32 MB

FLASH: 8 MB

Scanning JFFS2 FS: . done.

LCD: ready

FB: loading - ready

In: serial

Out: serial

Err: serial

 

Options:

1: Console on null

2: Console on ttyS0

3: Console on framebuffer

Select (1-3), other keys to stop autoboot: 0

=> bootp 100000 /D/temp/dbox2/gtx_pdxberlin_SAT_23.11.02_2x1_neu.img

BOOTP broadcast 1

BOOTP broadcast 2

BOOTP broadcast 3

BOOTP broadcast 4

BOOTP broadcast 5

 

Retry count exceeded; starting again

 

dan stopt ie ook.

doe ik een reset of geef ik het commando boot in dan doet ie gewoon verder.

Iemand enig idee?

Share this post


Link to post
denktenk

tik op het punt waar ie stopt in het venster het commando: reset in (+enter), waarschijnlijk doet ie het dan wel.


In het land der zwartkijkers is drie-oog koning.

Share this post


Link to post
Guest hagar

nee echt niet.

Als ik reset schrijf dan reset hij ook

Maar heb oplossing gevonden denk ik

via expert mode maar

 

ipv ganse flash speicheren

neem ik flash zonder boot

dan doet ie het wel

mr nog nt via dboot

Share this post


Link to post
Guest hagar

ben hier ook al beetje verder

Maar iets klopt niet met dboot

Na het loaden van min flash stopt ie gewoonweg.

 

 

 

debug: DDF: Calibrating delay loop... debug: DDF: 66.76 BogoMIPS

debug: BMon V1.0 mID 02

debug: feID 00 enxID 03

debug: fpID 52 dsID 01-fa.a0.c4.07.00.00-fe

debug: HWrev 01 FPrev 0.30

debug: B/Ex/Fl(MB) 32/00/08

dbox2:root> debug:

BOOTP/TFTP bootstrap loader (v0.3)

debug:

debug: Transmitting BOOTP request via broadcast

debug: Got BOOTP reply from Server IP 192.168.1.200, My IP 192.168.1.100

debug: Sending TFTP-request for file C/utils/sat/dbox2/boot/ppcboot_writeflash

will verify ELF image, start= 0x800000, size= 201596

verify sig: 262

boot net: boot file has no valid signature

Branching to 0x40000

 

 

ppcboot 0.6.4 (Apr 11 2002 - 16:10:44)

 

Initializing...

CPU: PPC823ZTnnB2 at 66 MHz: 2 kB I-Cache 1 kB D-Cache

Board: ### No HW ID - assuming TQM8xxL

DRAM: (faked) 32 MB

Ethernet: 00-50-9c-2a-b4-83

FLASH: 8 MB

LCD driver (KS0713) initialized

BOOTP broadcast 1

TFTP from server 192.168.1.200; our IP address is 192.168.1.100

Filename 'C/utils/sat/dbox2/tftpboot/logo-lcd'.

Load address: 0x130000

Loading: ##

done

LCD logo at: 0x130000 (0x1F9FFC0 bytes)

BOOTP broadcast 1

TFTP from server 192.168.1.200; our IP address is 192.168.1.100

Filename 'C/utils/sat/dbox2/tftpboot/logo-fb'.

Load address: 0x120000

Loading: #########

done

FB logo at: 0x0 (0x1FC0000 bytes)

AVIA Frambuffer

Input: serial

Output: serial

 

 

1: Console on ttyS0

2: Console on null

3: Console on framebuffer

Select (1-3), other keys to stop autoboot: 0

dbox2-ppcboot> bootp 100000 /D/dbox2/flashimage.img

BOOTP broadcast 1

TFTP from server 192.168.1.200; our IP address is 192.168.1.100

Filename '/D/dbox2/flashimage.img'.

Load address: 0x100000

Loading: #######################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################

done

 

dbox2-ppcboot>

 

 

Iemand idee hoe dat komt?

denk dat het iets te maken heeft met de flash protect

Share this post


Link to post
denktenk

Minflash?, die moet je niet gebruiken voor het inladen van een image.

Gewoon dbox2 bootmanager.

Overigens het bovenstaande logscherm lijkt goed.

Na het laden van de kruisjes stopt de info in het terminalscherm en gaat de info verder in de statusbalk onderaan het terminalscherm, misschien dat niet opgemerkt?.


In het land der zwartkijkers is drie-oog koning.

Share this post


Link to post
Guest hagar

Denktenk bedankt vr je snelle replay. Ik werk dus wel met Dboot hoor. Na het laden zoals je in vorige scherm kunt zien zie ik gewoon een blinkende cursor. Onderaan gebeurd er dus ook nts meer. Bovendien zie ik op min tv scherm wel staan Dbox II Boot manager is working with your flash. Verder wens ik er nog aan toe te voegen dat het wel mogelijk is gewoon commando's als help enz in te brengen op com terminal. Het ziet er naar uit dat ie ze gewoon nt wilt overschrijven van temp nr andere memmory.

En da's het probleem. Heb hem gisteren van stroomnet gehaald en sedert dan wil ie nt meer booten. Heb dan vanmorgen met dboot geprogt. Ging ook niet. Dan via expert mode. Daar kon ik dus ook nt de volledige eeprom erinspeikeren. Toen heb ik geprobeerd om via de gehele flash ohne boot dat ging wel. Jammer genoeg loopt ie nu vast dr ie zin logo nt vinden kan.

Share this post


Link to post
Guest hagar

Gevonden. MAN MAN. Het probleem was het volgende.

1 Ik heb mijn compoort op 57600 moeten zetten.

2 Ik had nog een ander kabeltje in min andere com poort steken

 

Als ik dit laatste eruit trok ging ie wel schrijven nr zin flash.

Share this post


Link to post
Sign in to follow this  




  • Hosting Fun

×
×
  • Create New...

Important Information

By clicking the accept button you specifically agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. If you don't agree, please leave this site.