Jump to content
Sign in to follow this  
Black Tiger

Ieks, BT doet ook weer eens iets hoor :o

Recommended Posts

Welnu, lachen, gieren, brullen, of net niet natuurlijk.

 

Ik was bezig met een Conax image. Maar ik heb ook die Dbox2 een tijdlang in doos gehad, dus dat was weer even wennen.

Probleem: Ook hiermee moet ik met de p133 werken.

 

Na enkele uren gestoeit te hebben en lezen en weer rommelen met de baudrate, lukte het uiteindelijk het image er in te zetten met de bootmanager met timeouts.

Regelmatig zo van #######T ###############T etc. maar uiteindelijk lukte het dan.

Ik had het wel gedaan door het image te renamen naar 13.img en door op start te drukken in te laden en dus niet via de load image feature.

 

Had ik het maar niet gedaan. Vriend Dbox2 meende derhalve dat ik een flash image met boottoestand er in aan het pompen was, en het was dus mooi gelukt, maar dbox2 wilde daarna wel niet meer fatsoenlijk opstarten c.q. startte wel op, maar bleef ergens tijdens het opstarten hangen omdat hij vmlinuz files mistte die hij nergens kon vinden.

 

Ik dus weer van "prachtig" want het was inmiddels al 02.00 en ik had ome Denktenk hier inmiddels ook al bijna ziek ge-icqt.

 

Oke weer lezen, oplossing gevonden. Base image van AlexanderW1.6.nogwat moest je er in zetten.

Ik dat weer gedaan op bovengenoemde wijze (ook met ppcboot en niet met ppcwriteflash) en dat lukte en HOERA. De box startte weer op.... althans dat dacht ik.....

Kreeg het venstertje waarbij ik moest kiezen op het display en ik koos middels de a/b voor Neutrino.

Heel fijn, dat werkte want displaytje zei even wat anders en kwam toen terug met de vraag of ik via ftp even in de /var/tmp directory de cdk.cramfs wilde plaatsen, dan op OK drukken en dan a.u.b. ook de ucodes in de ucodes directory.

Phew.. werd weer zoeken, maar gelukkig vond ik ze nog op het net (ja beide files, google rulez echt) en ze er in geftp't en HOERA! de dbox2 wenste te herstarten en funktioneerde ook nog, althans voor zover ik kon zien want ik heb bij de pc niet de mogelijkheid om scart en antenne kabel er in te pluggen.

Maar hij startte mooi door.

 

Ik dus weer van oke nog maar eens middels image flashen (op de normale manier dus) weer die conax versie erop, en dat lukte ondanks enkele #####T (dat is timeout) weer mooi, maar bij het opstarten krijgt ie eerst weer de ppcboot 1.1.6 en daarna loading kernel en daar blijft ie op hangen, verder gaat ie niet, en je krijgt in het beeld van de tv een heel mooi grijs DBOX2 te staan.

 

Ook met de bootmanager eraan actief om te loggen wenst meneer niet verder te booten.

Wel krijg ik een melding over een verkeerde magic in de cramfs???

 

Onnodig lang verhaal weer natuurlijk, en ik zal in mijn meteen hier op volgende reply de log geven, maar het is gedaan om beginners te laten zien dat je ook weer niet al te veel moet gaan klooien met je doos of voor welke problemen je kunt komen te staan.

 

Ik hoop dat iemand een oplossing heeft voor mijn probleem, ondertussen ga ik proberen of ik wel nog een oud image gewoon er op geflashed krijg.


Greetings, Black Tiger

Share this post


Link to post

Hier dus mijn opstartlog van de doos. Weet iemand wat dat wrong magic onderaan betekent en hoe ik dat probleem eventueel oplossen kan?

==================================================

_debug: DDF: Calibrating delay loop... debug: DDF: 66.76 BogoMIPS

debug: BMon V1.0 mID 02

debug: feID 00 enxID 03

debug: fpID 52 dsID 01-38.32.8f.07.00.00-4f

debug: HWrev 01 FPrev 0.30

debug: B/Ex/Fl(MB) 32/00/08

dbox2:root> debug:

BOOTP/TFTP bootstrap loader (v0.3)

debug:

debug: Transmitting BOOTP request via broadcast

debug: Given up BOOTP/TFTP boot

boot net failed

 

Flash-FS bootstrap loader (v1.5)

 

Found Flash-FS superblock version 3.1

Found file /root/platform/philips-dbox2/kernel/os in Flash-FS

debug: Got Block #0052

 

will verify ELF image, start= 0x800000, size= 203252

verify sig: 262

Branching to 0x40000

 

 

PPCBoot 1.1.6 (TuxBox) (Jul 12 2002 - 20:57:43)

 

CPU: PPC823ZTnnB2 at 66 MHz: 2 kB I-Cache 1 kB D-Cache

Watchdog enabled

Board: DBOX2, Phillips

I2C: ready

DRAM: 32 MB

FLASH: 8 MB

Scanning JFFS2 FS: . done.

LCD: ready

FB: loading - ready

In: serial

Out: serial

Err: serial

 

Options:

1: Console on null

2: Console on ttyS0

3: Console on framebuffer

Select (1-3), other keys to stop autoboot: 0

...............................................................

Un-Protected 63 sectors

### FS (cramfs) loading 'vmlinuz' to 0x100000

cramfs: wrong magic

### FS LOAD ERROR for vmlinuz!

=>

==============================================

En daar blijft ie dus staan en wenst niet verder te gaan.

Lijkt me ook logisch met een FS load error, ik ga er van uit dat FS voor File System staat.


Greetings, Black Tiger

Share this post


Link to post
Guest frans513487

Volgens mij is dit niet goed

Scanning JFFS2 FS: . done.

frans

Share this post


Link to post

Thanks Frans, zou heel goed kunnen, maar wat er ook fout aan is, ik weet niet wat ik er aan kan verbeteren.:(


Greetings, Black Tiger

Share this post


Link to post

Op zich is het niet zo verwonderlijk dat ie het jffs2 file system scant, want dat is -zeg maar- de VAR;-))))))))


In het land der zwartkijkers is drie-oog koning.

Share this post


Link to post
Guest frans513487

Hai met frans kijk hier maar

 

--------------------------------------------------------------------------------

 

nach dem standbild habe ich einen reset durchgeführt.

ausstecken-pfeil nach oben+standby taste-dann einstecken und 10 sec. warten,dann loslassen.

einmahl fuhr sie ohne probleme hoch dann beim hard standby kommt nur noch lade... und ein grün leuchtendes display.

die dbox2 bootet nur mit bootmanager per ftpboot und cdkroot.

wenn ich ein anderes image über die expertenfunktion flashe läuft alles normal.nur bei diesem nicht.

kann ich dieses image,das ich so wie es jetzt ist irgendwie bearbeiten zb das fehlende logo-lcd in den flash speicher kopieren.

 

 

hat jemand eine idee?

...................................

debug: BMon V1.0 mID 02

debug: feID 00 enxID 03

debug: fpID 52 dsID 01-d6.73.ca.07.00.00-30

debug: HWrev 01 FPrev 0.30

debug: B/Ex/Fl(MB) 32/00/08

dbox2:root> debug:

BOOTP/TFTP bootstrap loader (v0.3)

debug:

debug: Transmitting BOOTP request via broadcast

debug: Given up BOOTP/TFTP boot

boot net failed

 

Flash-FS bootstrap loader (v1.5)

 

Found Flash-FS superblock version 3.1

Found file /root/platform/philips-dbox2/kernel/os in Flash-FS

debug: Got Block #0052

 

will verify ELF image, start= 0x800000, size= 203252

verify sig: 262

Branching to 0x40000

 

 

PPCBoot 1.1.6 (TuxBox) (Jul 12 2002 - 20:57:43)

 

CPU: PPC823ZTnnB2 at 65.900 MHz: 2 kB I-Cache 1 kB D-Cache

Watchdog enabled

Board: DBOX2, Phillips

I2C: ready

DRAM: 32 MB

FLASH: 8 MB

Scanning JFFS2 FS: . done.

find_inode failed for name=ppcboot.conf

load: Failed to find inode

LCD: find_inode failed for name=logo-lcd

load: Failed to find inode

ready - can't find logo in flash - try network

BOOTP broadcast 1

ARP broadcast 1

TFTP from server 192.168.100.1; our IP address is 192.168.100.2

Filename 'logo-lcd'.

Load address: 0x100000

Loading: ##

done

..........

apofis

 

Back to top

 

 

Zahni

 

 

 

Joined: 24 May 2002

Posts: 917

 

Posted: Thu Jan 09, 2003 10:58 am Post subject:

 

--------------------------------------------------------------------------------

 

Das JFFS2-Dateisystem ist beschaedigt.

 

Basisimage neu flashen.

 

http://dboxupdate.berlios.de

 

Und irgendwie glaube ich nicht, dass das Image original ist.

 

 

 

ALS JE VEEL OM JE HEEN KIJKT DAN WEET JE VEEL!!!!!!!

Groetjes frans

Share this post


Link to post

Yep, dat neu einspielen is dus wat ik gisteren gedaan had, vandaar ook dat ie weer naar die ucodes vroeg enzo.

 

Ga het zometeen nog maar eens proberen, hopelijk gaat ie dan wel goed verder.

Ik hou jullie op de hoogte!


Greetings, Black Tiger

Share this post


Link to post

Oke, baseimage kreeg ik er op deze ouwe prul alleen weer in als ik het naar 13.img renamede en dan de ppcboot gebruikte i.p.v. de ppcboot-writeflash.

 

Dit werkte, Alex image deed het.

 

Weer een ander img onder de naam flashimage.img naar /var/tmp gepompt middels ftp en op de juiste manier weer ingelezen.

Leek weer goed te gaan, tot bij herstart, dan blijft de box weer hangen op "loadingkernel".

 

Hij doet hem dus niet uncompressen ofzo.

Daarna een nieuwstart gedaan en gelogt wat ie deed, en dan komt ie weer met die "magic" foutmelding helemaal onderaan. Hier is de log:

debug: DDF: Calibrating delay loop... debug: DDF: 66.76 BogoMIPS

debug: BMon V1.0 mID 02

debug: feID 00 enxID 03

debug: fpID 52 dsID 01-38.32.8f.07.00.00-4f

debug: HWrev 01 FPrev 0.30

debug: B/Ex/Fl(MB) 32/00/08

dbox2:root> debug:

BOOTP/TFTP bootstrap loader (v0.3)

debug:

debug: Transmitting BOOTP request via broadcast

debug: Given up BOOTP/TFTP boot

boot net failed

 

Flash-FS bootstrap loader (v1.5)

 

Found Flash-FS superblock version 3.1

Found file /root/platform/philips-dbox2/kernel/os in Flash-FS

debug: Got Block #0052

 

will verify ELF image, start= 0x800000, size= 203252

verify sig: 262

Branching to 0x40000

 

 

PPCBoot 1.1.6 (TuxBox) (Jul 12 2002 - 20:57:43)

 

CPU: PPC823ZTnnB2 at 65.900 MHz: 2 kB I-Cache 1 kB D-Cache

Watchdog enabled

Board: DBOX2, Phillips

I2C: ready

DRAM: 32 MB

FLASH: 8 MB

Scanning JFFS2 FS: . done.

LCD: ready

FB: loading - ready

In: serial

Out: serial

Err: serial

 

Options:

1: Console on null

2: Console on ttyS0

3: Console on framebuffer

Select (1-3), other keys to stop autoboot: 0

...............................................................

Un-Protected 63 sectors

### FS (cramfs) loading 'vmlinuz' to 0x100000

cramfs: wrong magic

### FS LOAD ERROR for vmlinuz!

=>

 

Ik snap er geen bal meer van. :(


Greetings, Black Tiger

Share this post


Link to post
Guest frans513487

Hai met frans

Ik zie dat het een philips d box2 is

waarom zet je deze er niet in RS-021115 enx/gtx modified

die is zeer goed voor de philips

DOE MIJ MAAR EEN NOKIA D BOX2

Share this post


Link to post

Hmmz.. enx/gtx modified? Volgens mij zit dat in dat conax image wat ik er in wil zetten ook verwerkt.

 

Maar het maakt niet uit. Jah, een Nokia zou ik ook wel willen maar op dat moment was niets anders beschikbaar en op dat moment werkte de Philips ook beter.

 

Ik heb veel gelezen, ook omtrent die kernel-cdk die af en toe op komt en die wrong magic of zoiets wat ie geeft.

 

De oplossingen passen daarbij niet op mij, maar ik kon er wel uit concluderen dat het dik aan de snelheid kon liggen en gezien ik time-outs heb bij het inladen van het image.....

 

De best opgegeven oplossing was nog image er opnieuw in laden, dus ik wacht effe, met een beetje geluk krijg ik vanavond een snellere machine te leen en dan proberen we gewoon opnieuw. :)


Greetings, Black Tiger

Share this post


Link to post

Ik zou het jullie nog laten weten.

 

Probleem was inderdaad dat de p133 te traag was. Nu heb ik een 2gig pc hier staan met een onaangepaste windows XP er op (dus niets aan die mediasensing verandert ofzo) en het image zat er in 1 keer goed op, geen problemen.

 

Naja.... Denktenk, welke satellites.xml heb je in dat image gebruikt? Zoals je weet moet je de Dbox2 opnieuw laten scannen zonder overschrijven, om de diseqc aan de praat te krijgen.

Het bleek dat ie Astra en Hotbird weer fijn inscande maar op de Sirius bleek ie niets te vinden.

Een bekend probleem bij de oudere satellite.xml files. Dus ik vraag me af... :)

 

Overigens maakt dit ook duidelijk dat het diseqc probleem bij de Dbox2 nog altijd bestaat en dat de diseqc ondersteuning veel beter kan en hier nog aan gewerkt moet worden, net als de ondersteuning voor de... wat was het ook alweer Henk? Eutelsat II F3? De 16 oost? Dacht het wel he?


Greetings, Black Tiger

Share this post


Link to post

Heb net een nieuwe settingslijst geupt naar http://wizard.irde.to/Settings/

 

Het niet kunnen ontvangen van sommige sats zit hem niet alleen in de satellites.xml, maar ook (denk ik) in de zapit.

 

Is de eutelsat W2 op 16 oost


In het land der zwartkijkers is drie-oog koning.

Share this post


Link to post
Sign in to follow this  




  • Hosting Fun

×
×
  • Create New...

Important Information

By clicking the accept button you specifically agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. If you don't agree, please leave this site.